Jump to content

My network connection is now broken

Recommended Posts

I had a computer that someone infected with Best Antivirus 2011.

Downloaded and ran the portable version of SUPERAntiSpyware.

Ran (took about 35min) and it looked like it cleaned everything.

After the reboot.. I found that I could no longer get an IP address, so no internet and no network.

I tried the following

1. Ran SUPERAntiSpyware Portable again, and selected REPAIRS then REPAIR the network connection. after reboot, did not fix.

2. Tried WinSockXPFix.exe - Still did not work after reboot

3. Tried a system restore to previous time and/date -> could not complete restore

4. next I tried deleting the NETWORK CARD, then rebooted, let it re-install -> still no go

I am at a complete loss.. Can anyone shed some light on this or have any ideas how to get the network back up and running.. It's urgent that I get this machine back up and running by tomorrow and I am out of ideas. As well I do not have time to re-install windows and all of the software required for this machine.

Any help would be greatly appreciated.


Share this post

Link to post
Share on other sites

There is no yellow exclimation marks... as well I deleted the network card and re-installed the driver.. It just cannot seem to get an ip and ipconfig /renew does not work and REPAIR on the netwok connection/card returns REPAIR CANNOT COMPLETE BECAUSE WE CANNOT RENEW THE IP.

Share this post

Link to post
Share on other sites

Check to be sure there are no proxy settings that aren't required. It would be found in your network connection configurations. No idea what version of Windows you are running, but poke around and you'll find it. Usually found by opening Internet Exploder, clicking the "tools" tab, clicking the connections tab, then "Lan" settings. If a proxy is not required, uncheck the box in front of the proxy server selection. Be sure your IP settings are correct. If you have a router, be sure you are set to connect to the proper network IP. IE: Static IP, DHCP, Gateway, etc. You can usually view the settings by opening a command prompt and typing "ipconfig /all" then enter at the command line. Leave off the quotes.

Share this post

Link to post
Share on other sites

I dealt with this a few weeks back on a clients computer. Same symptoms.

During troubleshooting, I found that the DHCP Service was off, and would not start, no matter what I tried.

It turns out that the malware had infected a file called "netbt.sys" and removed portions in the registry associated with the NetBTService. Somehow, with the malware installed, the Internet connection continued to work.

When the infected file was found and quarantined by another a/v, it left the NetBT service broken, thus no Internet connection, although everything in the network path looked correct.

Restoring the infected file did not help, and installing a new copy of the file did not help. The missing registy keys had to be rebuilt, in addition to replacing the netbt.sys file.

I was lucky to be able to rebuild the missing registry keys from a registry backup the user had on the system. Once I did this, everything worked again.

It would have been much easier to simply reinstall Windows, but I was determined to figure this one out, and my client did not mind me keeping her computer for awhile. B)

It took compiling info from multiple website forums to find the solution, but if anyone just cannot reinstall Windows, drop me a line and I can head you in the right direction. (Note: even with the solution, it is difficult to fix.)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...