Jump to content
OliverK

SAS Pro and Vista UAC confirmation

Recommended Posts

Can someone please advise how I prevent Vista from constantly wanting my confirmation to load SAS when I start my computer?

I'm sure there's a simple answer - neither my Spyware Doctor nor NOD32 require me to do this. How do I turn it off for SAS Pro (I'm running version 3.8.1002).

Share this post


Link to post
Share on other sites
Can someone please advise how I prevent Vista from constantly wanting my confirmation to load SAS when I start my computer?

I'm sure there's a simple answer - neither my Spyware Doctor nor NOD32 require me to do this. How do I turn it off for SAS Pro (I'm running version 3.8.1002).

Oliver, when you say Vista is asking for confirmation to load SAS when you start the computer does the SAS 'Bug' load to the system tray, along with your other start-up apps, and then you are getting the UAC request.

If this is the case, do you have SAS's options checked for Automatic Updates? Automatic Updating with SAS currently requires UAC permission and it is the program checking for updates automatically on start up that causes this 'confirmation' request from UAC. If this is the case you can either grant the permission to let it check for the updates or choose to turn off automatic updating and update manually from within the program, (that's what I do).

If you have have SAS set for Automatic Updating try unchecking those options just to see if you start up normally, without the UAC request.

Share this post


Link to post
Share on other sites
i uncheck automatic updating when starting and UAC enable....still same problem.

If the automatic updates are turned off, the SSUPDATE.EXE will not be launched, and won't cause the UAC to be triggered.

Share this post


Link to post
Share on other sites

I finally got all my programs transferred over to Vista.

As suspected, on reboot the UAC constantly wants my permission for SAS to run. I can't believe that it doesn't have an option to remember my setting. I even changed SAS's properties to "Run as Administrator", yet UAC still asks.

I turned off the UAC and all is well. I don't need or want it anyway. Ditto for Defender.

Share this post


Link to post
Share on other sites
I finally got all my programs transferred over to Vista.

As suspected, on reboot the UAC constantly wants my permission for SAS to run. I can't believe that it doesn't have an option to remember my setting. I even changed SAS's properties to "Run as Administrator", yet UAC still asks.

I turned off the UAC and all is well. I don't need or want it anyway. Ditto for Defender.

Well congratulations on getting all loaded on to Vista. Have to admit I was worried about some of my 'older' programs but with either good luck or a miracle I got everything I had installed and working, all be it with one or two 'workarounds' and the odd patch from the Vendor's where I could find one! You rushing out to buy a new printer now? :lol:

The problem I experienced in the thread you linked to earlier in this thread was a different issue to this, I think. I was getting a different start up 'behavioural' problem whereby I was getting the complete 'set-up options' window for SAS coming up again on every start up.

I have SAS loading with windows and since unchecking the options for automatic updates, (and resolving that other issue eventually), it loads fine without any UAC requests??? Plus when I run the updates manually from within the program I don't get a UAC 'request' either, it simply connects and downloads, if updates are available.

The big problem and a criticsm of UAC, (I read an article somewhere on this a while back), is that it does not give you an option to 'remember this setting', or even something along the lines of what a personal firewall might do in the early days of 'training' it. If you have something that needs the 'permission' to run you have to grant it every single time. Thankfully I don't have too many of those, and the few that I do have, (a couple of oldies), aren't used on a daily basis, or it would become a right pain. :roll:

I suspect many Vista users have just ended up turning it off like yourself.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×