Jump to content
sunniebear

A Quirk with SAS Pro 3.7 in Vista.

Recommended Posts

Hi, wondering if anyone has any ideas on this.

Since I upgraded from 3.6 to 3.7, (uninstalled 3.6 and did a fresh install of 3.7), everytime I start the computer and SAS loads I get a window asking if I would like to check for the latest updates, nothing happens if I click yes. I have tried it both ways clicking yes and on another start up clicking cancel, either way this dialogue box is then followed by the program set-up Wizard options. I already completed this during the install and did uncheck not to check for updates on start up. Again I have experimented and run through the steps again, unchecking that option, and on another occasion just clicking cancel. After doing either/or then the program opens, click close and we're under way.

The other thing is with this is that it is reverting back to an earlier database with each restart.

Tonight I uninstalled, downloaded the set up again and reinstalled. Went through all the Whizrds and then once launched updated manually from within the program, (I have been doing it like this with 3.6 due to UAC in Vista).

When the program was installed the database was Core:3228 Trace:1239, after manually updating, Core:3238 Trace:1249. I then did a restart to see if I had resolved the problem of the update request window and set-up Wizard appearing at every start up. It hadn't it still happened and when I clicked past these 2 windows to finally open the program interface the database had returned to Core:3228 Trace:1239 :shock:

I am thinking this is something to do with administrator rights in Vista. When I exit the program in the system tray I get 2 results when relaunching. If I just click the icon to relaunch I get the 2 windows again and the database has reverted back. If I right click and launch choosing 'Run as Administrator' I get the normal SAS 'Spalsh Screen' and it appaears in the sysrem tray with none of the other windows opening and when I open the program interface the datbase is what I last updated to, Core:3238, Trace:1249.

However after I have shut down and the next time I start the PC, or do a reboot for whatever reason I am back to the original behaviour again of the 2 windows and the database has reverted back again.

I have reinstalled twice now, I thought I would try right clicking the installer and 'Running as Adminisrator', but I got the same result :roll:

I do my installations with all other apps, shutdown, (exited), except the Vista Firewall. Defender was not turned completely off but real-time monitoring was turned off. I also only have the one account set up, myself, and I know it's naughty, but it is the administrator account :lol:

(Just some additional info. that might help).

I didn't have this happen with 3.6 and I don't really mind having to just cancel those 2 windows that appear on every start up to get going, but the database reverting back does concern me a bit.

Sorry this is a bit long winded, but I thought if I gave as much detail as possible someone might be able to pin point the problem. I have been playing with this for a few weeks now and have exhausted everything I can think of to try :cry:

Thank you in advance of any suggestions.

Share this post


Link to post
Share on other sites

I have tried a few more things today.

I unchecked in the preferences for SAS not to run at start up, I also unchecked the boxes in real-time for First Chance Prevention, (as I understand this is not available in Vista at the moment anyway?).

When I rebooted SAS did not start with windows, as intended. I launched from the icon and SAS started and I got the 'check for updates window' followed by the Set-Up Wizard options again. Once I get the program interface opened I checked in the preferencs again, and anything I had changed had been changed back, ie. the tick was in the box to run at start-up and the ticks where back in the boxes for First Chance Prevention. :cry:

I unchecked these again, rebooted and this time launched from the icon by right clicking and selecting 'Run as Administrator'. Instead of getting the 'check for updates window', followed by the Set-Up Wizard options, I just get the blue SAS 'Splashsceen' and the icon appears in the system tray. Then when I open the program, nothing has changed, the database is the one I last updated to earlier today, Core:3239 Trace:1250, and when I check in the preferences all the options I had unchecked are STILL unchecked. :D

So it seems if I don't run SAS at start-up and after I get started up, launch the program by 'Running as Administrator', everything will be as expected and any changes that have been made will stick. Any other way and I am back to the original problems.

The solution would seem to be to get the program to install under Administrator Rights and get those rights to stick :?: I have already tried an installation by right clicking the installer and 'Running as Administrator' and it didn't solve the problem.

I also encountered this problem with another program in Vista when I first upgraded but once I had launched it as 'Run as Administrator' once I didn't have to do it again.

I am still learning myself about all of this in Vista and I am sure there is just something really simple that I am overlooking but as I mentioned before I just installed 3.6 with a double click on the installer and none of this happened.

At least, I do seem to have hit upon a work around to all of this at the moment by not running at start-up and then launching by 'Run as Administrator', once windows has started up. :)

Share this post


Link to post
Share on other sites

When you installed the product originally, did you install using the Admin account - we are not seeing these issues in our testing and you and siliconman01 are the only ones reporting such issues.

Share this post


Link to post
Share on other sites
When you installed the product originally, did you install using the Admin account - we are not seeing these issues in our testing and you and siliconman01 are the only ones reporting such issues.

Yes, I am the only person who uses this PC and there is only the one account set up on it, mine and I am the administrator.

As I thought about this, being the only user, I uninstalled again and this time on the installation I checked to use 'only for myself', instead of 'for all users'. It didn't work, everytime I reboot I still get the 'check for updates window' and then the set-up options Wizard again. Ah well, it was just something that crossed my mind to try.

I will stick to my workaround at the moment, uncheck to run at start up and then launch with 'run as Administrator'. it seems to be the only way I can launch the program normally and keep any changes made to it since the installation.

As the First Chance Prevention currently isn't available in Vista I don't think I am losing out on anything security wise by doing that, when it does become available, I would like to be able to run at start up and take advantage of this feature. :)

I'll leave alone now for a few days and have a think, maybe something else will come to mind and maybe have another go at the weekend.

Share this post


Link to post
Share on other sites

Hi, I have another update.

UAC is what is causing the problem. :evil:

I turned it off and SAS behaves normally I can set to start with windows, reboot, and when the program launches, no 'check for updates' request window, no 'set-up Wizard options' window, just SAS's normal blue splash screen and the bug in the system tray, any changed preferences are still 'changed' and the database is still the one updated to today, Core:3240 Trace:1251. Rebooted a couple of times, exited the program and restarted with a double click on the icon. No problems. :D

So I uninstalled, once again, and reinstalled, still with UAC turned off. Played around again with a couple of reboots, exiting/restarting the program etc. etc., no problems again.

Then I turned UAC back on. All the issues back again. :cry: the 'request for upgtates' window, 'set-up Wizard options' Window, and when I just click to cancel them the program is back to the original database at time of the installation and any changes I made to the preferences are changed back to default again.

I am back to my original workaround of setting SAS not run at start up, and then once windows has started up I launch it with a right click and 'Run as Adminstrator'. UAC is obviously not letting SAS run with administrator rights at start up, for some reason.

I uninstalled another program I had an issue with that needed admin. rights to run, and reinstalled it, I ran it the once with a right click and 'run as admin.', like I had done before, and after that it was ok and I didn't have to keep selecting run as admin. to launch it. (Just wanted to check my Vista installation hadn't gone 'pear shaped' for some reason, but all has been very well with it up until this 'niggle'.

So I have pin pointed the culprit, but as of yet not the solution but at least knowing the cause is half the battle, :D (I think!).

I don't really want to turn UAC off on a permanent basis. (I actually don't mind it, unlike some users, and I think it does add another layer of protection to your defences, provided you pay attention to the prompts). If anyone thinks differently to this I am open to listening to the argument. :wink:

Share this post


Link to post
Share on other sites

I have waited to report back, to be sure, but I seemed to have resolved this issue. I have been shutting down an starting up for 5 days in a row now and the problem hasn't reoccured. SAS 'bug' appears in the system tray, normal SAS splashscreen, and database is staying at what it was on the latest update. :D

I have no idea how this solved it. I tried to think of what was different when I installed 3.6 to 3.7. Only difference was that 3.6 was the trial which I later purchased and activated using the activation option on the 'right click' menu.

Recreating a similar scenario I uninstalled SAS once again and reinstalled but didn't opt to put in my registration code and activate when prompted during the installation, which happened just before I got the window to check for the latest updates and then the program set up Wizard options. After the installation was complete I then entered my code and activated using that option on the 'right click' menu.

The issues I was experiencing have not reoccured since :D

The only thing that will change back to default is if you uncheck First Chance Prevention, next time you reboot it does check those boxes again. Perhaps this is just a 'cosmetic' issue as First Chance Prevention isn't available for Vista as of yet? (Not an isssue for me, just an observation).

Anyway, I am just pleased to have it all working normally again, as it was with 3.6, whatever the great old PC 'voodoo doll' was that was causing the issue :lol:

Share this post


Link to post
Share on other sites

Just a quick comment. I upgraded from 3.7 to 3.8 today, none of the previous problems mentioned in this thread, upgrading from 3.6 to 3.7 reoccured :D

Share this post


Link to post
Share on other sites
Just a quick comment. I upgraded from 3.7 to 3.8 today, none of the previous problems mentioned in this thread, upgrading from 3.6 to 3.7 reoccured :D

Thanks for the updates, glad things are working well for you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...