Jump to content
silkphoenix

Scheduled Scanning

Recommended Posts

Hello,

I upgraded my SAS Professional Lifetime subscription to 5.0.1108 on August 5. Ever since then my scheduled scanning does not work anymore. I have scheduled it to run at 2am every day and it has been working great before the upgrade. I have disabled and enabled, removed and added tasks and still does not work. My laptop does go to sleep after 10 minutes, however, I have checked "Wake computer from sleep to perform this task" so it should not stop the scanning from starting. Could someone please tell me how to solve this problem as it's very inconvenient to do manual scanning.

Thank you very much.

PS: I am now using my laptop, so out of curiosity, I added a scheduled scanning in about 5 minutes to see if it works. No, it didn't. The scheduled scanning did not start. So obviously it's not because my laptop went to sleep causing the scheduled scanning from starting. Somehow the new version disable the scheduled scanning tasks from working properly. Will this be fixed very soon?

Share this post


Link to post
Share on other sites

Hello,

I upgraded my SAS Professional Lifetime subscription to 5.0.1108 on August 5. Ever since then my scheduled scanning does not work anymore. I have scheduled it to run at 2am every day and it has been working great before the upgrade. I have disabled and enabled, removed and added tasks and still does not work. My laptop does go to sleep after 10 minutes, however, I have checked "Wake computer from sleep to perform this task" so it should not stop the scanning from starting. Could someone please tell me how to solve this problem as it's very inconvenient to do manual scanning.

Thank you very much.

PS: I am now using my laptop, so out of curiosity, I added a scheduled scanning in about 5 minutes to see if it works. No, it didn't. The scheduled scanning did not start. So obviously it's not because my laptop went to sleep causing the scheduled scanning from starting. Somehow the new version disable the scheduled scanning tasks from working properly. Will this be fixed very soon?

You may want to try downloading the latest install package from our website and re-install. What version of Windows are you using? Is the user account an Administrator user or a Standard/Limited user?

Share this post


Link to post
Share on other sites

You may want to try downloading the latest install package from our website and re-install. What version of Windows are you using? Is the user account an Administrator user or a Standard/Limited user?

Do I need to uninstall the one I have first before re-install? Thank you.

Share this post


Link to post
Share on other sites

Do I need to uninstall the one I have first before re-install? Thank you.

You can just run the setup program, it will perform any needed uninstall actions before starting.

Share this post


Link to post
Share on other sites

You can just run the setup program, it will perform any needed uninstall actions before starting.

After I reinstall, I scheduled a Quick Scan 5 minutes later. The scheduled Quick Scan never shows up. It seems like the reinstall did not solve the problem. Any other suggestions? Thank you.

Share this post


Link to post
Share on other sites

You may want to try downloading the latest install package from our website and re-install. What version of Windows are you using? Is the user account an Administrator user or a Standard/Limited user?

And to answer your question. I am using Windows XP and I am the Administrator.

Share this post


Link to post
Share on other sites

I have the same problem which did not exist until V5 came out. I did the reinstall. It did not help. Also am using Windows XP and am the Administrator. I've changed nothing else on my computer, so I believe there is a glitch in V5.

Share this post


Link to post
Share on other sites

I have the same problem which did not exist until V5 came out. I did the reinstall. It did not help. Also am using Windows XP and am the Administrator. I've changed nothing else on my computer, so I believe there is a glitch in V5.

I agree. I went ahead to uninstall the program (from Add/Remove Programs under Control Panel) and then install the downloaded 5.0 program. Then I scheduled a Quick Scan 5 minutes later. The scheduled scanning never comes up. So I am now 100% sure that the upgrade disable the scheduled scanning somehow. I hope the developer will fix it very soon as it's very annoying to have to do it manually since I want to do the scan in the middle of the night when I am not using the laptop. For the time being, I guess I just have to start the scan manually.

NOTE: My friend has a FREE version of V5 and he has no problem with the schedule scanning. It seems odd that when you actually paid for the program, you have the problem. Shouldn't be the other way round?

Share this post


Link to post
Share on other sites

I agree. I went ahead to uninstall the program (from Add/Remove Programs under Control Panel) and then install the downloaded 5.0 program. Then I scheduled a Quick Scan 5 minutes later. The scheduled scanning never comes up. So I am now 100% sure that the upgrade disable the scheduled scanning somehow. I hope the developer will fix it very soon as it's very annoying to have to do it manually since I want to do the scan in the middle of the night when I am not using the laptop. For the time being, I guess I just have to start the scan manually.

NOTE: My friend has a FREE version of V5 and he has no problem with the schedule scanning. It seems odd that when you actually paid for the program, you have the problem. Shouldn't be the other way round?

SUPERAntiSpyware 5.0 uses the Windows Task Scheduler to perform scheduled scanning and updates. If you go into Control Panel and open up Scheduled Tasks, you should see the SUPERAntiSpyware tasks. You can get a little more information about when Windows thinks it last ran the task and possible error codes if it failed to start.

As for your friend running the Free Edition and Scheduled Scans, I'm not sure how that's happening; Scheduled Scanning is not a feature on the Free Edition.

Share this post


Link to post
Share on other sites

SUPERAntiSpyware 5.0 uses the Windows Task Scheduler to perform scheduled scanning and updates. If you go into Control Panel and open up Scheduled Tasks, you should see the SUPERAntiSpyware tasks. You can get a little more information about when Windows thinks it last ran the task and possible error codes if it failed to start.

As for your friend running the Free Edition and Scheduled Scans, I'm not sure how that's happening; Scheduled Scanning is not a feature on the Free Edition.

I did go to the Windows Task Scheduler and it listed SUPERAntiSpyware as I scheduled. But it said "Last Run Time--Never" and no error code (which has been two days now). Scheduled Task is on my friend's FREE VERSION, and which I have been using for a few years before I actually bought the LIFETIME SUBSCRIPTION earlier this year. have been using SUPERAntiSpyware for years and schedule scanning has always worked perfectly until I upgraded to V5.

Could I downgrade to the previous version? Something is wrong with V5 which disabled the Schedule Scanning with Windows XP.

Share this post


Link to post
Share on other sites

When I go to Control Panel/Scheduled Tasks, it shows Never for the Last Run Time for scanning AND it shows Never for Last Run Time for updating. There are no error messages. I too would like to downgrade back to the previous version which worked fine. Also, the Find Out What's Running on My Computer does not work (on either Firefox 5 or IE7).

Share this post


Link to post
Share on other sites

1. My XP is fully updated.

2. I just went through the entire MS task scheduler troubleshooter at http://support.microsoft.com/kb/308558. Everything was fine except the box "allow service to interact with desktop" was not checked. I checked it, but this did not solve the problem. The scheduled scan would not start.

3. There was nothing in the Task Scheduler to show any error and I did confirm all the scheduled task settings under each tab.

Share this post


Link to post
Share on other sites

Do you have any other scheduled tasks and do they show as running correctly?

Does the task manager log show any indication as to why the SAS task won't run?

Share this post


Link to post
Share on other sites

Do you have any other scheduled tasks and do they show as running correctly?

Does the task manager log show any indication as to why the SAS task won't run?

I basically have the same issue as Newbie. As I mentioned in my post, SAS WAS ABLE to start the scheduled scanning every day BEFORE I upgraded to V5. I know that before I have the scan report showed as soon as it's finished so I can manually delete the detected items.

So I don't think it's Windows XP or my laptop's problem. Somehow V5 couldn't start the scheduled scanning as scheduled. Something has changed in V5 which disabled it.

Share this post


Link to post
Share on other sites

I basically have the same issue as Newbie. As I mentioned in my post, SAS WAS ABLE to start the scheduled scanning every day BEFORE I upgraded to V5. I know that before I have the scan report showed as soon as it's finished so I can manually delete the detected items.

So I don't think it's Windows XP or my laptop's problem. Somehow V5 couldn't start the scheduled scanning as scheduled. Something has changed in V5 which disabled it.

Yes, I understand that. My two previous questions were asked to determine if the issue is within SAS itself, or if SAS has somehow altered XP's Task Scheduler characteristics.

Share this post


Link to post
Share on other sites

1. The Task Manager Log gives no indication of any problem.

2. I have no other Scheduled Tasks in the Task Scheduler.

Ok thanks.

You might want to try and schedule a task (like opening IE), as that would provide a critical clue as to what's happening. Other than that, the developers will have to continue with you on this, as there is nothing else I can suggest.

Share this post


Link to post
Share on other sites

Ok thanks.

You might want to try and schedule a task (like opening IE), as that would provide a critical clue as to what's happening. Other than that, the developers will have to continue with you on this, as there is nothing else I can suggest.

I have a question: Does SAS scheduler depends on Windows XP Task Scheduler to run the task?

I have AVG Anti-Virus which is scheduled to run scanning every day as well. It has no problem whatsoever. So even though my Windows XP Task Scheduler might be corrupted, it should not stop SAS from scanning at the scheduled time, unless of course, it depends on Windows XP Task Scheduler to do the task, unlike AVG, which doesn't.

Thank you.

Share this post


Link to post
Share on other sites

I have a question: Does SAS scheduler depends on Windows XP Task Scheduler to run the task?

Yes.

That's why I asked if other tasks were running correctly and/or to try scheduling a task to run (like opening IE).

Share this post


Link to post
Share on other sites

I have a question: Does SAS scheduler depends on Windows XP Task Scheduler to run the task?

I have AVG Anti-Virus which is scheduled to run scanning every day as well. It has no problem whatsoever. So even though my Windows XP Task Scheduler might be corrupted, it should not stop SAS from scanning at the scheduled time, unless of course, it depends on Windows XP Task Scheduler to do the task, unlike AVG, which doesn't.

Thank you.

Share this post


Link to post
Share on other sites

1. According to the release notes, SAS scheduler does now with V5 depend on MS Task Scheduler (and apparently did not with V4 and other earlier versions).

2. There is a problem with my Task Scheduler because it will not run other programs without some password and I have no clue what kind of password it is looking for. I do note that when I look at the details for SAS in the Scheduled Task, the "Set Password" is grayed out so it does not let you set a password, which may be the problem.

Share this post


Link to post
Share on other sites

At this point, it's safe to determine that the issue is Task Scheduler not functioning correctly. That can be due to misconfiguration of TM's attributes, or an antivirus/firewall blocking TM/SAS.

1) What other security programs (antivirus/firewall) are being run in real time?

2) In Services, does TM show as "Started"?

3) Do the Event Viewer logs provide any clues?

Share this post


Link to post
Share on other sites

1. According to the release notes, SAS scheduler does now with V5 depend on MS Task Scheduler (and apparently did not with V4 and other earlier versions).

2. There is a problem with my Task Scheduler because it will not run other programs without some password and I have no clue what kind of password it is looking for. I do note that when I look at the details for SAS in the Scheduled Task, the "Set Password" is grayed out so it does not let you set a password, which may be the problem.

#1 is correct.

#2: The password is only valid when you manually schedule a task and include a password. With that being said, XP's TM is known to malfunction if there is no user account password. For example, have a look at this thread: http://forums.techarena.in/windows-xp-support/69675.htm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×