Jump to content
Sign in to follow this  
redsparro

SAS 5.0.1086 delay in system shutdown process

Recommended Posts

Hi all,

Am running Win 7 x64 SP1. Get the following entry logged in Event Viewer, i only looked because i had an application that would hang at shutdown, and turns out to be SAS.

This application caused a delay in the system shutdown process:

File Name : SUPERANTISPYWARE.EXE

Friendly Name : SUPERAntiSpyware Application

Version : 5, 0, 0, 1086

Total Time : 3055ms

Degradation Time : 3759ms

Incident Time (UTC) : ‎2011‎-‎05‎-‎18T12:02:50.913187400Z

It's something i noticed pre V 5, but thought that it may be something that would be rectified in the new release. When i perform a shutdown where i have manually closed SAS, the computer doesn't hang. When i mean hang, i'm referring to the Waiting for background programs to close popup. Have tried disabling the scan at system shutdown option, but no luck.

Share this post


Link to post
Share on other sites

I've had the same problem with any version of SAS I've ever used and that's been for years.

I just learned to live with it.

Share this post


Link to post
Share on other sites

Most of you who see this will probably be using the realtime protection. More specificly the options found under "first chance prevention", these options will slow things down as it clearly states.

On lower spec computers it will be very noticeable compared to not using this option.

Share this post


Link to post
Share on other sites

Most of you who see this will probably be using the realtime protection. More specificly the options found under "first chance prevention", these options will slow things down as it clearly states.

On lower spec computers it will be very noticeable compared to not using this option.

Yea, i thought that maybe it was to do with first chance prevention, but after having unchecked the scan at system shutdown option, it still hangs.

Share this post


Link to post
Share on other sites

Hi

This may be related to your system having a low memory state or high disk activity at the time of shutdown. Try booting your system, then letting all startup applications finish so your machine is idle. Next, close any applications that may have started with your system (like your e-mail client, or other security tools). Run SUPERAntiSpyware (open the main window) then shut down your system. Chances are SUPERAntiSpyware won't slow your shutdown. I understand this is a somewhat "ideal" situation, but sometimes processes get blamed for slowing the shutdown when really it's only the combination of other events that trigger the event viewer entry.

- Dave

Share this post


Link to post
Share on other sites

Hi

This may be related to your system having a low memory state or high disk activity at the time of shutdown. Try booting your system, then letting all startup applications finish so your machine is idle. Next, close any applications that may have started with your system (like your e-mail client, or other security tools). Run SUPERAntiSpyware (open the main window) then shut down your system. Chances are SUPERAntiSpyware won't slow your shutdown. I understand this is a somewhat "ideal" situation, but sometimes processes get blamed for slowing the shutdown when really it's only the combination of other events that trigger the event viewer entry.

- Dave

Yea, that makes sense, but the fact is with the exact same setup, but MBAM running with realtime protection enabled, my system shuts down cleanly without problems. It is only when i have been running SAS with realtime protection that there is a delay, which is what lead me to the conclusion that SAS is the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×