Jump to content
gpzbc

Startup Drivers for SAS Portable?

Recommended Posts

I'm wondering if someone more knowledgeable than me, might be able to give me some advice and help?

I am using Windows 7 64-bit Home Premium and I recently downloaded the SAS Portable version. Perhaps I was mistaken, but I assumed I could run it on my Win7 64 bit system from a flash drive. Well, SAS Portable ran just fine. But soon after I ran it, I started noticing some errors in my event viewer.

The first error was event ID 1060. It was described as: "C:\Users\XXX\AppData\Local\Temp\SAS_SelfExtract\SASDIFSV. has been blocked from loading due to incompatibility with this system. Please contact your software vendor for a compatible version of the driver." I was able to stop that error from occurring simply by deleting the SAS Portable Temp folder. SOLVED

The second error was event ID 7000 and is described as: "The SASENUM service failed to start due to the following error: The system cannot find the file specified." Once again, I was able to prevent this error from occurring simply by deleting the SAS Portable Temp folder. SOLVED

The third error is the stubborn one. It is event ID 7026 and is described as: "The following boot-start or system-start driver(s) failed to load: SASDIFSV SASKUTIL." So I immediately searched for the mentioned drivers thinking they would be found under Device Manager if I chose the option to "Show Hidden Devices" and looked under the "non plug and play" category. However the drivers were not located there. I assume they are not there because I used the Portable version of SAS rather than the standard application (because I have seen them there with the standard version of SAS).

So when I couldn't find the drivers, I started scouring the SAS Forums. I found the the SAS_StartupFix.exe that is being offered. I downloaded it, ran it, chose the option to disable the startup drivers, and then restarted my computer as prompted. Unfortunately, that didn't work. I'm still getting event ID 7026 errors every time I restart my computer.

So I'm wondering what I have to do to make this error stop occurring? I considered deleting the three registry keys: SASDIFSV, SASENUM, and SASKUTIL. But I thought I should check in with someone more knowledgeable than I am before doing so. Are there any dangers in removing those three registry keys? Keep in mind, I used the portable version of SAS on this computer and may not ever use it again.

Thanks so much for your advice and help as I try to figure out this problem.

Share this post


Link to post
Share on other sites

Ha!! I just found the SUPERAntiSpyware Uninstallation Assistant. So I downloaded it, ran it, and restarted my computer. And it fixed the problem! No more event ID 7026 errors. And after checking the registry, it looks like this uninstallation assistant deleted the registry keys that I mention in my earlier post.

I have to say that it seems a bit odd that I had to download and run an uninstallation assistant for the portable version of a program that I never installed on my computer. :blink:

Either way, the problem is fixed and I am happy. :)

Share this post


Link to post
Share on other sites

We will have a 64-bit version of the portable shortly and you won't see those errors.

Thank you! I'll be looking forward to it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...