Jump to content
Sign in to follow this  
bigchief

Always starts at first run

Recommended Posts

Superantispyware always starts like it's the first run. It's asks for the language, do I want to check for updates, protect the home page, etc... It downloads the updates and says it installs them. If I let it setup, it will show the correct core, trace and database update versions. I can run a scan just fine. I have it set to not autostart with Windows. The next time I try to start it, it goes through the same setup routine again. If I tell it not to check for updates, it shows that I am back to the original installed version, that I have never updated it, and that I have never run a scan.

I'm not having any other problems with this machine. The only other anti-malware software that runs all the time is AVG AV Free. This is only happening on one of my computers. I am a computer tech. About 70% of what I do is remove malware from other peoples computers. I know my machine is clean. I have uninstalled, manually deleted program folders and program entries in the registry, and reinstalled several times with the same results. I just don't understand why it seems to be stuck on the first run every time.

Any help would be appreciated.

In case anybody needs to know:

Windows XP Pro SP3

Asus M2n32 SLI Deluxe Wi-fi edition

Athlon 64X2 6400

4 GB Crucial Ballistix ram

2 x 250 GB WD Hard drives

2 x Geforce 9800GTX

Share this post


Link to post
Share on other sites

I have fixed that problem, though I'm not sure I fixed the root cause of the problem. For some reason it didn't give me proper registry permissions under HKCU. I gave myself full control, and then it started working properly. As to why it didn't give me permissions for the key, I don't know.

Share this post


Link to post
Share on other sites

I was just taking a read of your first message and would have suggested taking a look at the startup options on the HKCU also just incase there was something there too... Would you be so kind as to explain how you resolved your issue with a little more detail so others with the same issue can mimic your actions?

Many regards

insomnai

Share this post


Link to post
Share on other sites

Start -> Run -> Regedit -> Navigate to Hkey_Current_User\Software\SUPERAntiSpyware.com

Right click on the key - Choose permissions - Make sure that your account, administrators, and System have a check in the "Full Control" check box.

You might have to do it in Safe Mode, depending on your version of Windows, and you may need to restart after making the change. If you don't understand any of that, or if you are not familiar with editing the registry, it might be best to not mess with the registry.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×