Jump to content
SKaVeN

SAS 4.15.1000 Stalling

Recommended Posts

This seems to be a common problem recently experienced by some SAS users but I have now encountered this same problem myself.

I know it's nothing on my PC that causes this because I just did an avast! boot scan & it never stalls on the same file - a different one each time.

I'm currently running the Pro edition in the trial period (because I like the scheduling option) & I have installed SAS on other PCs as well as this one (in the past) & have never had this problem before.

The Elapsed Time is still running but the scan stops & I the only way I can get out of it is pressing Ctrl+Alt+Del & ending the software in the System Processes.

I've reinstalled the software several time but the problem persists. I have deselected Use Direct Disk Access in the Preferences but it didn't do any good. Most frustrating.

Is there a fix that we know of yet (other than uninstalling it completely & replacing it with 4.2)?

Thank you.

Share this post


Link to post
Share on other sites

Thanks but I think I may have figured out the problem so have some information that may be of some interest or relevance to other users.

I just let the SAS scan run out last night & found out that when it stalls on a file, & you just leave it long enough, it will eventually start moving again (albeit a long time).

The files it always stops on are ones called thumbs.db:encryptable which appear is some of my picture directories. Once it scans past them it zips along nicely.

I use ThumbsPlus to manage all my pictures & have some of them grouped together to run as a slideshow (rather than using a screensaver) which is a feature ThumbsPlus.

Interestingly, SAS only stalls on thumbs.db:encryptable files in the directories that I use in the slideshow. I tried looking through all the files (including the hidden ones) in the directory myself but can't see it there. Weird. It must be something created by the ThumbsPlus slideshow feature that confuses SAS...

Also, I disabled TeaTime. If I can get SAS stabilised I'll most probably trash SpyBot altogether.

Share this post


Link to post
Share on other sites

thumbs.db:encryptable

It would appear that slideshow software is adding ADS to thumbs.db file and this is possibly where the scanning conflict(stalling) is occuring.

If you go to Preferences>>>Scanning Control and uncheck "scan Alternate Data Streams" does the issue still persist ?

Share this post


Link to post
Share on other sites

I don't know I haven't tried that. I'll give it a go & let you know. Will un-checking Scan ADS significantly reduce the effectiveness of the SAS scan?

Share this post


Link to post
Share on other sites
I don't know I haven't tried that. I'll give it a go & let you know. Will un-checking Scan ADS significantly reduce the effectiveness of the SAS scan?

In theories yes as it will no longer scan Alternative Data Streams for malware.

That said my suggestion is purely based from a diagnostic perspective to hopefuly identify the scanning issue on your computer.

Share this post


Link to post
Share on other sites

Okay I just ran a full scan without Scan ADS selected & it took two & a half hours which is exactly half of what it takes when it is selected.

Share this post


Link to post
Share on other sites

My name is Don Fowler. I'm an engineer working on SAS. This is an interesting problem that we haven't been able to reproduce or track down as of yet. Your testing is very appreciated. Would you mind doing a custom scan of a folder that seems to have the "hang" with ADS enabled and ignore non executable files along with scan only known types disabled. I'd like to see if it still seems to hang. What I suspect from your information is that there are a large number of files and alternate data streams that aren't being scanned, but have to be "qualified" as non-scan items. Also, pay attention to the drive activity if it does appear to hang.

Thanks

Don

Share this post


Link to post
Share on other sites

Okay, I reselected ADS & deselected Ignore Non-Executable Files & Scan Only Known Types. I set up a Custom Scan of just the group of picture directories that each have one of these mysterious thumbs.db:encryptable files & no, it didn't hang on them this time either, & this time it just called them thumbs.db.

Share this post


Link to post
Share on other sites

Thanks. I suspect that the thumbs.db is not the problem.. just the last file that was processed. Would you mind doing the same thing, but do a scan of your entire drive instead of just the directory where the problem occurred?

It would be nice to see if the hang occurs in the scenario you normally see it with the options you just tested with.

Thanks

Don

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...