Jump to content
wekebu

firewall blocking error

Recommended Posts

I keep getting the error: There was an error trying to retrieve definitions. Make sure your firewall is not blocking SUPERANTISPYWARE.EXE from accessing the Internet.

I first installed SAS two versions ago and got this error. No definition updates. Even with Window's firewall turned off. I unintalled, got a new version and same error.

Today, I uninstalled using the SASUNINST.EXE file, rebooted, downloaded ver 4.15.1000 same error.

I'm running Vista with all the updates and SP1. I'm running as admin. No 3rd party firewalls, only Window's firewall. I have turned it off to no avail. SAS will run a scan, but simply won't update the definitions.

Suggestions please?

Share this post


Link to post
Share on other sites

Are you using some kind of proxy program? Go to internet explorer, and in the options, look for Tools>>Internet Options>>Connections, select your connection and click Settings, look if there is any proxy setting. Also check the LAN Settings

Share this post


Link to post
Share on other sites
Are you using some kind of proxy program? Go to internet explorer, and in the options, look for Tools>>Internet Options>>Connections, select your connection and click Settings, look if there is any proxy setting. Also check the LAN Settings

Internet Properties, Connections Tab, LAN Settings: nothing checked. Proxy server, unchecked. There isn't anything to 'select your connection and click settings'. Vista menu's different than the one you have?

Share this post


Link to post
Share on other sites
Are you using some kind of proxy program? Go to internet explorer, and in the options, look for Tools>>Internet Options>>Connections, select your connection and click Settings, look if there is any proxy setting. Also check the LAN Settings

Internet Properties, Connections Tab, LAN Settings: nothing checked. Proxy server, unchecked. There isn't anything to 'select your connection and click settings'. Vista menu's different than the one you have?

I'm using IE 6. Maybe you're using IE 7? If yes you could make a google search on proxy settings. I'm saying this because I had the same problem before and it was because of proxy settings.

Share this post


Link to post
Share on other sites
I'm using IE 6. Maybe you're using IE 7? If yes you could make a google search on proxy settings. I'm saying this because I had the same problem before and it was because of proxy settings.

I have IE7, but use Firefox as my default browser. I did check Internet Options in Control Panel, in Firefox and in IE7, all do not have proxy settings selected. I really appreciate the suggestions. This is frustrating!

Share this post


Link to post
Share on other sites
Internet Properties, Connections Tab, LAN Settings: nothing checked. Proxy server, unchecked. There isn't anything to 'select your connection and click settings'. Vista menu's different than the one you have?

Nothing is checked? Not even the "Automatically detect settings" check box?

Also, are you by any chance using a host file? Host file entries can be added by rogue software and that will effectively block access to certain sites.

Share this post


Link to post
Share on other sites

I just remembered, maybe you should check if you allowed SSUpdate.exe to connect to the internet in your firewall. That program is necessary for updating.

Share this post


Link to post
Share on other sites

The folder C:\Users\[your user name]\AppData\Local\Temp\ does exist and doesn't have any System or Read Only attributes on? The Hidden attribute is the default value for that folder.

My Vista version is Home Premium 32-bit SP1, with Defender and Windows firewall activated. Similar to yours I suspect and I have no issues with SAS at all. Problem is of course that it could be anything that's interfering. :?

Share this post


Link to post
Share on other sites

Nothing is checked? Not even the "Automatically detect settings" check box?

Also, are you by any chance using a host file? Host file entries can be added by rogue software and that will effectively block access to certain sites.

Hi, no, not even Automatically detect settings. Humm, perhaps because I'm using Hughes satellite?

Host file? I don't know what that is, so no?

Share this post


Link to post
Share on other sites

I would check the "Automatic detect settings" to see what happens and if it makes no difference than you can always uncheck it again.

If you don't know what a host file is, I'm sure you're not using one. :)

Share this post


Link to post
Share on other sites

I am having same problem. I started a thread and then found this one. Have you ever figured it out ? I cannot even get mine to acvtivate even with firwalls turned off. Would like to know if you got it figured out - thanks

Share this post


Link to post
Share on other sites

I know that it came late.

But I had a lot of trouble updating Antispyware trial as well as free version.

I checked and checked but can't find the solution.

On this forum,in this thread,Nightcap mentioned to check the proxy settings in the internet settings page of control panel to check proxy settings.And he talked about Automatically Detect settings.

I found that I didn't have it checked.

And then I selected it and updated the Superantispyware again.

Voila,this time,it worked.

I just hope that this information can help someone out there having trouble updating Superantispyware.

This is not about Firewall,at least,for me.

I have ESET Smart Security 4 and Zonealarm Firewall.

Both of them were put into interactive mode to ask me if some program tried to access the internet.

Both firewalls didn't notify me anything before I chose the Automatically detect internet settings,

as if the updater was not working at all.

Once I selected Automatically detect settings,both firewalls asked for it.

Therefore please check that setting if you are having trouble updating Superantispyware.

If it doesn't work even after that,there must be some other problem that you are facing.

Good Luck.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×