Jump to content
HAN

4.1.1046 manual update woes...

Recommended Posts

After installing SAS Pro, I always update manually (download to a PC at another location and install later at home.) Prior to version 4.x, I never had any issues.

But starting with 4.0, manual updates no longer seem to work correctly. 4.0 would not update the Core and Trace versions without deleting the Processlist.bin file first. And now, when manually updating 4.1, the MSI installer runs every time. I've tried the manual update 3 or 4 times. The Windows installer runs, re-creates the SAS Pro shortcut on the desktop (which I always delete) and then exits. It does update the Core and Trace version numbers, but this seems like a very long way to go to get things up to date.

I have not yet tried another install (since I have to take the PC to another location) but before I did, I wanted to check and see if I'm the only one having manual update oddities...

Share this post


Link to post
Share on other sites

I manually updated another SAS Pro PC and did NOT have the MSI issue. So, I will start over on the PC with the problem and see how it goes...

Share this post


Link to post
Share on other sites

Well, at first a re-install didn't help, but in the end, it did! :shock: It appears that the SAS Pro shortcut I was clicking to re-start SAS Pro (after the manual update) was somehow invoking the MSI installer. Once I stopped using it, and used the one in the Program Group, the installer no longer attempted to run. If I had discovered this before the re-install, I'm thinking I wouldn't have needed to re-install. As to how the shortcut became linked to the MSI installer, I haven't a clue... :?:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...