Jump to content
snagel

Problems with new version of SUPERANTISPYWARE Updates

Recommended Posts

I have been having trouble with this newest version of SUPERANTISPYWARE 4.1.1046. Everytime I try to check for updates I get the following message.

There was an error trying to retrieve definitions. Make sure your firewall is not blocking

SUPERANTISPYWARE.EXE from accessing the Internet.

I have checked the LIVE ONE CARE firewall and it doesn't show any problems with blocking anything for SUPERANTISPYWARE.

What do I need to do to get this to work right.

Everything worked just fine before using this program until yesterday.

I have Windows XP sp3. XP sp3 was just upgraded yesterday also.

Share this post


Link to post
Share on other sites

Can you temporarily disable your firewall and try to get an update. That would tell for sure if it was a firewall issue or something else. Once done ensure you turn your firewall back on.

Share this post


Link to post
Share on other sites

also have a problem with updating 411046 ..its ok on my xp..and on one of my 2k with core 3472 trace 1463..but on my laptop 2k wont update..I have core 34690 trace 1460 on it..says unable get latest definitions .I disabled my firewall..also rite clicked taskbar icon..no luck. thanks for assist..rog

Share this post


Link to post
Share on other sites

Today 1.6. I try to install the latest version of FREE Superantispyware on Vista without SP1. It is not possible to update definitions - Windows Vista claims that that communication is blocked by windows firewall. I tried to switch off the firewall - It didn't help; I created a firewall rule for SAS - it didn't hep; I installed Vista SP1 - it didn't help... Really I've no idea what is wrong.

I would like to install SAS definitions manually, but where to store definition files in the Vista file system?

Share this post


Link to post
Share on other sites

I installed the latest Spybot version (allowed control center integration). From that moment is it possible to update SAS?! Probably Spybot opens hidden firewall ports that new windows service packs close...

Share this post


Link to post
Share on other sites

for what it is worth, i will share my experience.. first, i have "SAS pro build 4.x"..

after reading this post, i ran the updater and i saw the same problem! i had not had any problems with updating SAS, before this.. (i have had SAS pro build 4.x installed for a few days)

however, note that i had "start superantispyware when windows starts" and "show superantispyware icon in the system tray" UNCHECKED.. i did not have these options unchecked, before, when i was not having problems with updating SAS..

when i saw the problem, i was running the updater from within a limited user account, so i tried running the update from within an administrator account, to see if that made a difference, but it didn't..

then, i re-enabled both "start superantispyware when windows starts" and "show superantispyware icon in system systray", and then, after doing that, the updater ran successfully..

apparently, on my computer, at least, unchecking "show superantispyware icon in the system tray" makes the difference between the updater's functioning properly and not functioning properly..

Share this post


Link to post
Share on other sites
for what it is worth, i will share my experience.. first, i have "SAS pro".. after reading this post, i ran the updater and i saw the same problem! i had not had any problems with updating SAS, before this.. (i have had SAS pro build 4.x installed for a few days)

however, note that i had "start superantispyware when windows starts" and "show superantispyware icon in the system tray" UNCHECKED.. i did not have these options unchecked, before, when i was not having problems with updating SAS..

when i saw the problem, i was running the updater from within a limited user account, so i tried running the update from within an administrator account, to see if that made a difference, but it didn't..

then, i re-enabled both "start superantispyware when windows starts" and "show superantispyware icon in system systray", and then, after doing that, the updater ran successfully..

Likley another security package or firewall blocking us during the startup phase....

Share this post


Link to post
Share on other sites

Likley another security package or firewall blocking us during the startup phase

nothing on my computer is blocking SAS-files from running.. however, i understand that that can be a problem..

SAS's updating-process works fine as long as i have "show superantispyware icon in the system tray" checked..

Share this post


Link to post
Share on other sites

I am having the same problem since upgrading to v4.15.10 this morning. Everything was fine before. I am sure it is not my firewall (LooknStop) blocking the updates..

And I have the icon showing in the tray.

Help would be appreciated.

Windows XP2

Share this post


Link to post
Share on other sites
I am having the same problem since upgrading to v4.15.10 this morning. Everything was fine before. I am sure it is not my firewall (LooknStop) blocking the updates..

And I have the icon showing in the tray.

Help would be appreciated.

Windows XP2

What specific issue are you having?

Share this post


Link to post
Share on other sites

The one that started this thread.

There was an error trying to retrieve definitions. Make sure your firewall is not blocking

SUPERANTISPYWARE.EXE from accessing the Internet.

Share this post


Link to post
Share on other sites
The one that started this thread.

There was an error trying to retrieve definitions. Make sure your firewall is not blocking

SUPERANTISPYWARE.EXE from accessing the Internet.

What firewall are you using?

Share this post


Link to post
Share on other sites

see my msg above re 411046 wont updateon my 2k so uninstalled and today for the heck of it downloaded sas again and got the 41510 version samo samo..errory trying to retreve definitions..when I loaded it zonelarm asked if ok for sas.exe and I said yes..because this program is free we dont get help on this matter?? you keep saying check firewalls and we keep saying our firewall is ok and even disable it..will leave this on for a week then ditch it..lot of programs on net with none of these problems. but.works fine on my xp.will keep on that..thanks..Robert

Share this post


Link to post
Share on other sites

Robert:

You are incorrect in stating that there is no support for the free version of SAS. We are one of very few vendors that provide free support for all our products including the free version of SAS which scans, identifies and removes malware WITHOUT purchasing a thing. :) Have you submitted a Customer Service Request HERE: :o

https://www.superantispyware.com/csrcreateticket.html :wink:

Share this post


Link to post
Share on other sites

to add to my previous posts, here, i uninstalled the "old" version of SAS and then installed the new "SAS build 4.15".. during the installation-process, i was prompted to update the program, to run the updater, which i did.. then, when the installation process was finished and the program began running, i got an "update reminder", again prompting me to run the updater, and saying that "SAS had not been updated in 47 days".. however, when i tried to run the updater, again, i got the same error that has been mentioned..

i went ahead and adjusted the preference-settings, closed SAS.. restarted SAS-with the SAS icon running in the systray, ran the updater, again (from the SAS-icon's menu), and it worked, that time..

i am running SAS-pro..

update: i started SAS (which only showed the icon running in the systray), clicked "scan", in the icon's menu, to open the GUI.. then i clicked "check for updates" and got the same "error" that has been mentioned..

if i run the updater from the SAS icon's menu, i don't get the error..

saserror1ei2.jpg

Share this post


Link to post
Share on other sites
to add to my previous posts, here, i uninstalled the "old" version of SAS and then installed the new "SAS build 4.15".. during the installation-process, i was prompted to update the program, to run the updater, which i did.. then, when the installation process was finished and the program began running, i got an "update reminder", again prompting me to run the updater, and saying that "SAS had not been updated in 47 days".. however, when i tried to run the updater, again, i got the same error that has been mentioned..

i went ahead and adjusted the preference-settings, closed SAS.. restarted SAS-with the SAS icon running in the systray, ran the updater, again (from the SAS-icon's menu), and it worked, that time..

i am running SAS-pro..

update: i started SAS (which only showed the icon running in the systray), clicked "scan", in the icon's menu, to open the GUI.. then i clicked "check for updates" and got the same "error" that has been mentioned..

if i run the updater from the SAS icon's menu, i don't get the error..

saserror1ei2.jpg

This means your firewall is blocking the update access.....plain and simple.

Share this post


Link to post
Share on other sites

nick, i didn't think that my firewall was the problem, but when i disabled my firewall, SAS was able to update, properly..

the problem was that i am blocking "theplanet", ip address-range 74.52.0.0 - 74.55.255.255, and SAS's updater tries to connect to multiple ip addresses, there.. i block "theplanet" because there is lots of malware, and other "criminal activity", there..

as for others who have been having problems with updating SAS, maybe there were problems with the servers at "theplanet" at the time:

http://tech.slashdot.org/article.pl?sid=08/06/01/1715247

i wish SAS would use someone other than "theplanet" to host SAS updates.. if SAS's updater only connected to one ip address there, i could handle that, but, when i ran SAS's updater, it connected to multiple ip addresses, there, which makes it difficult for me to create custom firewall-rules for downloading the updates, while still blocking "theplanet", as a whole..

Share this post


Link to post
Share on other sites

i wish SAS would use someone other than "theplanet" to host SAS updates.. if SAS's updater only connected to one ip address there, i could handle that, but, when i ran SAS's updater, it connected to multiple ip addresses, there, which makes it difficult for me to create custom firewall-rules for downloading the updates, while still blocking "theplanet", as a whole..

Do you realize The Planet/Ev1Servers hosts literally over a hundred thousand servers between their locations? They are a main backbone/hosting solution for many major companies. We have many servers that handle our updates, web and database traffic so connecting to a single IP is not practical as we have to distribute the load over many servers. If we had a single IP it would also be easier for people to try and attack our servers.

I am not sure why in the past few days you have had an issue with just about every aspect of our product, etc. - you have been using the product for over 2 years.

Share this post


Link to post
Share on other sites

To Pandato..sorry if I didnt state my msg correctly I know and see these posts that you do help and give info..I was trying to say so many posts saycant update definitions even showing the sas reply "ck your firewall" I did send a cust svc email with same info..and again apologize if I didnt present my problem correctly.. you have enuf work without my throwing my 2 cents in...thanks..Robert

Share this post


Link to post
Share on other sites

Robert. no problem, just wanted to make sure that you were aware of the customer support available as we take great pride in that. Best regards. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×