Jump to content
silverfox

How long does it take to update the application

Recommended Posts

I am a fully paid up subscriber, yet notification was issued last monday that a new version was available yet it still has not shown up in our automatic updates.

As a paid subscriber I think this is too much. One of the reasons I paid was because of the updates which has not happened. And yes to all those who will shout, I could download manually but why. That is part of the subscription.

Share this post


Link to post
Share on other sites
I am a fully paid up subscriber, yet notification was issued last monday that a new version was available yet it still has not shown up in our automatic updates.

As a paid subscriber I think this is too much. One of the reasons I paid was because of the updates which has not happened. And yes to all those who will shout, I could download manually but why. That is part of the subscription.

It was available as soon as it was announced - your firewall is likley blocking SSUPDATE.EXE (our updater) from accessing the Internet - thus you have not been informed of the update.

Right-click the SUPERAntiSpyware icon and select "Check for Updates".

Share this post


Link to post
Share on other sites

Sorry for hijacking this thread, but I'm a Pro user too and I'm (sorta) having the same issue. Only difference is that the definitions are always updated manually and the firewall is not blocking SSUPDATE.EXE.

I should also mention that since installing SAS on my new Vista desktop last month, the small window that informs users that the definitions are up to date at the lower bottom right, never shows. Nor the window that gives details about the added protection after a definitions update.

My old laptop (W2K) however, also with SAS Pro, got the update the very first day when I manually checked for updates.

So, what's the verdict? :)

AMD Athlon 64 X2 Dual Core

3GB Ram

Vista Home Premium Service Pack 1

Share this post


Link to post
Share on other sites
Sorry for hijacking this thread, but I'm a Pro user too and I'm (sorta) having the same issue. Only difference is that the definitions are always updated manually and the firewall is not blocking SSUPDATE.EXE.

I should also mention that since installing SAS on my new Vista desktop last month, the small window that informs users that the definitions are up to date at the lower bottom right, never shows. Nor the window that gives details about the added protection after a definitions update.

My old laptop (W2K) however, also with SAS Pro, got the update the very first day when I manually checked for updates.

So, what's the verdict? :)

AMD Athlon 64 X2 Dual Core

3GB Ram

Vista Home Premium Service Pack 1

Something is blocking SSUPDATE.EXE or you have auto-updates off for program updates. There is no window that shows in the lower right for definition updates, ONLY program updates. :)

Share this post


Link to post
Share on other sites

Something is blocking SSUPDATE.EXE or you have auto-updates off for program updates. There is no window that shows in the lower right for definition updates, ONLY program updates. :)

I use the same SAS settings for both computers and the W2K laptop doesn't check for program updates when SAS starts also. Still, I never had any problem with program updates in the past on that machine. That makes it difficult to understand why Vista won't update.

Furthermore SSUPDATE is allowed full access to the Internet. I will activate 'Check for program updates...' and see what happens. If that should fail, can I download the new version manually and install it over the existing version without problems?

Share this post


Link to post
Share on other sites

I tried the 'Check for program updates when application starts' without the desired result. Then I tried to manually update with the Windows firewall off. That also didn't work.

Guess the only thing left is a manual program update, although I really dislike that idea?

Also my question why the 2 windows are never shown on my Vista desktop still need to be answered, if possible. Could the update problem and the windows that have "disappeared" be connected to the same issue?

Share this post


Link to post
Share on other sites
I tried the 'Check for program updates when application starts' without the desired result. Then I tried to manually update with the Windows firewall off. That also didn't work.

Guess the only thing left is a manual program update, although I really dislike that idea?

Also my question why the 2 windows are never shown on my Vista desktop still need to be answered, if possible. Could the update problem and the windows that have "disappeared" be connected to the same issue?

Submit a support request here and we'll run a diagnostic to see what might be blocking the updates:

https://www.superantispyware.com/support.html

When you check for program updates, you are right-clicking the SUPERAntiSpyware icon by the system clock and selecting the "Check for Updates", NOT the one on the main screen correct? The one on the main screen ONLY checks for definition updates.

Also, you don't have "work offline" checked in IE do you ?

Share this post


Link to post
Share on other sites
Submit a support request here and we'll run a diagnostic to see what might be blocking the updates:

https://www.superantispyware.com/support.html

When you check for program updates, you are right-clicking the SUPERAntiSpyware icon by the system clock and selecting the "Check for Updates", NOT the one on the main screen correct? The one on the main screen ONLY checks for definition updates.

Also, you don't have "work offline" checked in IE do you ?

I will submit a support request in a few minutes.

Yes, I'm right clicking on the icon as I have been doing for the past 2 years and no, I'm not working off line. :) SAS is the only program that has this problem of the many that need to update.

Share this post


Link to post
Share on other sites

The firewall is not blocking SAS. All definition updates are delivered automatically when they are released. It is only the program update that is missing.

Share this post


Link to post
Share on other sites

Am I missing something here. :?:

I understood one of the major changes in 4.1 was that it overcame the UAC issue which prevented the update notification from working correctly and the auto updating of the programme.

Certainly on my Vista PC it was necessary to do a download and manual install for 4.0 and 4.1, whereas auto update worked perfectly under XP - but hopefully manual programme updates are in the past !i

Share this post


Link to post
Share on other sites

As mine is Vista Home Prem, I wonder if I will have to do a manual install. Bit of a bummer when there is nothing to say about it anywhere ( that program updates on vista must be done manually )

Share this post


Link to post
Share on other sites
Am I missing something here. :?:

I understood one of the major changes in 4.1 was that it overcame the UAC issue which prevented the update notification from working correctly and the auto updating of the programme.

Certainly on my Vista PC it was necessary to do a download and manual install for 4.0 and 4.1, whereas auto update worked perfectly under XP - but hopefully manual programme updates are in the past !i

If you were having the UAC issues on Vista with 4.0, you may need to manually update to 4.1 and you won't have the problem in the future.

Share this post


Link to post
Share on other sites

UAC is not showing on my system. Definition updates occour as and when required. Program updates do not. If I have to update manually all the time then I feel robbed of my money.

As I am the OP I feel that my original question has not been answered but the highjackers has. Not very good protocol this.

Share this post


Link to post
Share on other sites

Hi silverfox,

My apologies. I would not have posted my question if our issue(s) didn't have so much in common. My reasoning was that a possible solution would be helpful to others too. The main thing here is trying to find an answer for this problem and opening a new thread didn't seem logical.

Nightcap

Share this post


Link to post
Share on other sites
UAC is not showing on my system. Definition updates occour as and when required. Program updates do not. If I have to update manually all the time then I feel robbed of my money.

As I am the OP I feel that my original question has not been answered but the highjackers has. Not very good protocol this.

You are not getting "robbed" of your money - if you want a refund, we can certainly issue you one - I assumed you would also submit a support request so we can see what on YOUR system is blocking the updates, here is the link in direct respect to your question so you will know we are answering your question as well.

Submit a support request here and we'll run a diagnostic to see what might be blocking the updates:

https://www.superantispyware.com/support.html

Share this post


Link to post
Share on other sites

I came upon the same issue on my vista computer and 2 clients who are running xp. The version this was happening on was 3.9. On Vista it was the pro version, on xp -one computer it was pro version, one was the free version.

All 3 of them would not show the updater had an update, either by itself or if you clicked on check for program updates and did it manually.

So i uninstalled this version 3.9 and went to the website and installed the 4.1 free/pro versions.

Then i tested the updater again and now it worked. Even though there were no updates to the version- this time the box popped up and said so.

robin

Share this post


Link to post
Share on other sites
The version this was happening on was 3.9.

My current version is 4.0.1154 Pro.

Share this post


Link to post
Share on other sites
The version this was happening on was 3.9.

My current version is 4.0.1154 Pro.

Something on your system is blocking the updater - we are trying to determine what this is via the support ticket.

Share this post


Link to post
Share on other sites
Something on your system is blocking the updater - we are trying to determine what this is via the support ticket.

I realize that and I'm not being impatient, I only wanted to let Robin know that the version she's referring to and mine are not the same. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...