Jump to content
Sign in to follow this  
Grumpy

Internet Options disabled on IE

Recommended Posts

Firstly, YES I have tried the registry edit.

I have cleared the infestation. At some point I lost the ability to go into the "Internet Options" on the IE tool menu. It's the usual 'talk to your admin' message.

The problem is that when I went to:

HKEY_CURRENT_USER/Software/Policies/Microsoft

there wasn't even an entry for IE there. I downloaded IE7 from Microsoft and installed it again, and the problem is still there. I have no idea if this was something I did in being over-zealous in trying to TRULY clear my system of even the debris of previous infections or if this was something new. Currently, all software says I'm clean. I've manually looked for new files in various usual directories and feel confident it's all dealt with.

Being confident this is some sort of left-over issue doesn't help me fix it sadly. Could there be a re-mapping of the "Internet Options" command from the menu and THAT is what's locked? There's nothing else in the Policies directory other than 'System Certficiates'.

"Internet Options" IS available from the control panel, so that's something at least.

Anyone have any ideas?

Share this post


Link to post
Share on other sites

Thanks for all of those options, Seth. Unfortunately, none of them have helped. :(

It's good to be reminded of the SaS repair section, certainly! I'm not sure the security console had an option to restore the settings. The registry entries provided in the third link were interesting and gave me more things to look at, but the one pertaining to IE was the one I'd already made sure was set correctly.

It did help point out some new registry areas to at least check, though. I've not found anything yet though.

Thanks again for the response. I still wonder if I've just messed something up by getting gung-ho with cleaning.

Share this post


Link to post
Share on other sites

You're welcome.

Try this:

Internet Options>Advanced>Restore the advanced settings, then reset Internet Explorer settings.

Share this post


Link to post
Share on other sites

I assumed you meant the "Internet Options" from the Control Panel, which does work. I restored the Advanced Settings. This didn't let me back into the IE menu link to Internet Options, though. It still has the 'contact your admin' warning.

I also assumed by 'reset IE settings' that you mean to make sure security and privacy were back to their safe levels, which I did just do.

Thanks again for the advice. Hopefully we'll figure it out. For now it's still doing the same thing though. :(

Share this post


Link to post
Share on other sites

I tried out a free checker that was recommended by some folks. It found some old files related to Vundo I think, but I believe they were from one of the original infections and cut off from being active.

However, it did list possible problematic registry entries. I'd had the Zbot problem and so I knew that dxdss.sys entries were references were to it. I went into my registry and searched for them and deleted the two I found. It was only later that I considered trying the Internet Options again and voila! Fixed! I'm pretty sure that's what fixed the problem.

If anyone else has the problem, that might be another thing to add to the list of things to try to fix it. I'm sorry that I can't recall the locations of the entries, but I was more intent on getting rid of the references. They were 'safe' in that the rootkit was removed a while back, but I hated having them there.

Thanks again for all of the help. It's greatly appreciated!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...