Jump to content
HBOY

Scans Forever

Recommended Posts

HBOY   

I have used SAS for years and have had no problems. Today I have tried to do a full scan and it stalls forever on certain files. It was running 2 hours and I finally stopped it. I uninstalled and then reinstalled it is right now at an hour and has been on the same file for twenty minutes. It scans the memory and registry fine, its the files thats causing the trouble. First post so I dont know what files or logs to post. Thanks.

Share this post


Link to post
Share on other sites
pharkit   

It could be the same problem as mine (http://forums.superantispyware.com/index.php?/topic/8723-superantispyware-hangs/). It looks like there might be a bug in the latest release (6.0.1230). Can you try the following and see if it helps.

Open SAS. Press 'System Tools'.

196 30-Dec 03.35 PM.png

 

Select 'Advanced Scan Settings'.

 

197 30-Dec 03.35 PM.png

 

Press 'Modify Excluded File Locations.

 

197 30-Dec 03.36 PM.png

 

Press the + button and add the following path to the 'Excluded Folders' list: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Accessories

Simply copy and paste that path directly into the 'folder' entry and it will add it automatically.

 

198 30-Dec 03.36 PM.png

 

Now press 'Done' then 'OK' then 'Done'. Now try doing another scan and see if it's quicker. That solution worked for me and I had a very similar problem to you.

 

Share this post


Link to post
Share on other sites

I am seeing the same issue on the Free Version.  I have tried using the Exclude list but it still fails to progress when it hits a random .LNK file.  I have also tried to use the Troubleshooting entries to Disable Kernel and Direct Disk access.  I have uninstalled and re-installed SAS to clear any possible file errors.  Using the Stop Scan button on the scan does not stop/halt the program.  In Task Manager the process shows around 32% CPU usage when it is stuck and requires using End Task to close it down.  SAS Core service shows as running but is showing using 0% of CPU.

In Event Viewer the event id is 1002 with task category (101)

SAS Free Edition Version is 6.0.1230

Operating System
            Windows 10 Home 64-bit
        CPU
            Intel Core i5 6500 @ 3.20GHz    36 °C
            Skylake 14nm Technology
        RAM
            16.0GB Dual-Channel DDR3 @ 799MHz (11-11-11-28)
        Motherboard
            ASRock Z170 Pro4/D3 (CPUSocket)    31 °C
        Graphics
            E2240 (1920x1080@60Hz)
            SMBX2235 (1920x1080@59Hz)
            HP x2301 (1920x1080@60Hz)
            Intel HD Graphics 530 (ASRock)
            4096MB ATI AMD Radeon R7 200 Series (Sapphire/PCPartner)    33 °C
            CrossFire Disabled
        Storage
            55GB KINGSTON SV300S37A60G (SSD)    28 °C
            238GB ADATA SX900 (SSD)    32 °C
            2794GB Seagate ST3000DM001-1ER166 (SATA)    36 °C
            59GB Kingston SSDNow V Series 64GB (SSD)
            1862GB Western Digital WD My Passport 259F USB Device (SSD)    28 °C
        Optical Drives
            TSSTcorp DVDWBD SH-B123A
            ELBY CLONEDRIVE SCSI CdRom Device
        Audio
            Realtek High Definition Audio

 

sasfe1.JPG

 

sasfe2.JPG

 

sasfe3.JPG

 

sasfe4.JPG

 

Edited by Wandererer
Added SAS Version & basic system specs

Share this post


Link to post
Share on other sites
HBOY   

Exact same thing, cannot close it out once it hangs up. I have to open task manager to close it. Since this is a known problem I hope they fix it soon.

Share this post


Link to post
Share on other sites
pharkit   

I worked out that it's bitdefender on my computer causing the issue. After including SAS in the  'List of processes excluded from scanning' & 'List of files and folders excluded from scanning' section of bitdefender, SAS now runs fine. This is only since the '6.0.1230' release of SAS.

The previous post I made about changing the exceptions in SAS itself can be ignored.

Share this post


Link to post
Share on other sites
HBOY   

Could you please walk me through that process. I cannot seem to find where the exclude list is at, and exactly what did you enter in that list. Thanks.

Share this post


Link to post
Share on other sites

Hello Everyone -

 

1) Open SUPERAntiSpyware
2) Click "System Tools"
3) click Advanced Scan Settings
4) Unchecked "Follow shortcuts (*lnk) during scan
5) Click 'OK' on the bottom right.

Let me know the results.

Share this post


Link to post
Share on other sites
20 hours ago, SUPERsupport said:

Hello Everyone -

 

1) Open SUPERAntiSpyware
2) Click "System Tools"
3) click Advanced Scan Settings
4) Unchecked "Follow shortcuts (*lnk) during scan
5) Click 'OK' on the bottom right.

Let me know the results.

This worked a treat.  Scan is now completing without the freeze.  Can not following the .lnk be a security issue?

Share this post


Link to post
Share on other sites

Hello all -

We recommend if you are having this issue you upgrade to version 6.0.1232 to fix it, available in both the Free and Professional Editions.

Free Edition users click HERE for 6.0.1232

Professional Edition users click HERE for 6.0.1232

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×